$re = '~^
https?://
(?:
(?!tbm=(?:isch|news)) # first neg. lookahead
(?!param1=432) # second
\S
)+
$~mx';
$str = 'https://www.google.com/search?q=test&tbm=isch&randomParameters=123
http://www.google.com/thisworks
https://google.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);