// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
https?://
(?:
(?!tbm=(?:isch|news)) # first neg. lookahead
(?!param1=432) # second
\S
)+
$").unwrap();
let string = "https://www.google.com/search?q=test&tbm=isch&randomParameters=123
http://www.google.com/thisworks
https://google.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}