import re
regex = re.compile(r"""
^
https?://
(?:
(?!tbm=(?:isch|news)) # first neg. lookahead
(?!param1=432) # second
\S
)+
$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("https://www.google.com/search?q=test&tbm=isch&randomParameters=123\n"
"http://www.google.com/thisworks\n"
"https://google.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")