re = /^
https?:\/\/
(?:
(?!tbm=(?:isch|news)) # first neg. lookahead
(?!param1=432) # second
\S
)+
$/mx
str = 'https://www.google.com/search?q=test&tbm=isch&randomParameters=123
http://www.google.com/thisworks
https://google.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end