#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/user[a-z0-9-]{1,}"
Local $sString = "Имеется строка, в которой хранится URL типа:" & @CRLF & _
"https://site.com/user12345" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Нужно посредством регулярных выражений получить ID (что после user). Также есть нюанс в том, что некоторые пользователи могут устанавливать уникальный URL для своего профиля, т.е. вместо" & @CRLF & _
"https://site.com/user12345" & @CRLF & _
"" & @CRLF & _
"может быть" & @CRLF & _
"https://site.com/username777"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")