re = /\/user[a-z0-9-]{1,}/
str = 'Имеется строка, в которой хранится URL типа:
https://site.com/user12345
Нужно посредством регулярных выражений получить ID (что после user). Также есть нюанс в том, что некоторые пользователи могут устанавливать уникальный URL для своего профиля, т.е. вместо
https://site.com/user12345
может быть
https://site.com/username777'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end