package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/user[a-z0-9-]{1,}`)
var str = `Имеется строка, в которой хранится URL типа:
https://site.com/user12345
Нужно посредством регулярных выражений получить ID (что после user). Также есть нюанс в том, что некоторые пользователи могут устанавливать уникальный URL для своего профиля, т.е. вместо
https://site.com/user12345
может быть
https://site.com/username777`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}