using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/user[a-z0-9-]{1,}";
string input = @"Имеется строка, в которой хранится URL типа:
https://site.com/user12345
Нужно посредством регулярных выражений получить ID (что после user). Также есть нюанс в том, что некоторые пользователи могут устанавливать уникальный URL для своего профиля, т.е. вместо
https://site.com/user12345
может быть
https://site.com/username777";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}