use strict;
my $str = 'Имеется строка, в которой хранится URL типа:
https://site.com/user12345
Нужно посредством регулярных выражений получить ID (что после user). Также есть нюанс в том, что некоторые пользователи могут устанавливать уникальный URL для своего профиля, т.е. вместо
https://site.com/user12345
может быть
https://site.com/username777';
my $regex = qr/\/user[a-z0-9-]{1,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}