#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}-\d{4}-\d{14}-\d{2}-\d{3}-\d{9}-\d-\d{8}\/\d$"
Local $sString = "99999999999" & @CRLF & _
"99-9999-99999999999999-99-999-999999999-9-99999999/9" & @CRLF & _
"999-9999-99999999999999-99-999-999999999-9-99999999/9" & @CRLF & _
"asfd99-9999--99-999-999999999-9-99999999/9" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")