// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}-\d{4}-\d{14}-\d{2}-\d{3}-\d{9}-\d-\d{8}\/\d$").unwrap();
let string = "99999999999
99-9999-99999999999999-99-999-999999999-9-99999999/9
999-9999-99999999999999-99-999-999999999-9-99999999/9
asfd99-9999--99-999-999999999-9-99999999/9
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}