import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}-\\d{4}-\\d{14}-\\d{2}-\\d{3}-\\d{9}-\\d-\\d{8}\\/\\d$";
final String string = "99999999999\n"
+ "99-9999-99999999999999-99-999-999999999-9-99999999/9\n"
+ "999-9999-99999999999999-99-999-999999999-9-99999999/9\n"
+ "asfd99-9999--99-999-999999999-9-99999999/9\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}