const regex = /^\d{2}-\d{4}-\d{14}-\d{2}-\d{3}-\d{9}-\d-\d{8}\/\d$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{2}-\\d{4}-\\d{14}-\\d{2}-\\d{3}-\\d{9}-\\d-\\d{8}\\\/\\d$', 'gm')
const str = `99999999999
99-9999-99999999999999-99-999-999999999-9-99999999/9
999-9999-99999999999999-99-999-999999999-9-99999999/9
asfd99-9999--99-999-999999999-9-99999999/9
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}