package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}-\d{4}-\d{14}-\d{2}-\d{3}-\d{9}-\d-\d{8}\/\d$`)
var str = `99999999999
99-9999-99999999999999-99-999-999999999-9-99999999/9
999-9999-99999999999999-99-999-999999999-9-99999999/9
asfd99-9999--99-999-999999999-9-99999999/9
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}