#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\w\s]+[\w\(\):]+[\w\(\)<\-\s{=;+*%\.}]+"
Local $sString = "def g(n:Int) = {" & @CRLF & _
" var vec = Vector.fill(0)(Vector.fill(0)(1))" & @CRLF & _
" for (p <- 1 to n) {" & @CRLF & _
" var vec2 = Vector.fill(0)(1)" & @CRLF & _
" for (q <- (p-1)*n+1 to p*n) {" & @CRLF & _
" vec2 = vec2 ++ Vector(q)" & @CRLF & _
" }" & @CRLF & _
" if (p%2==1) vec = vec ++ Vector(vec2)" & @CRLF & _
" else vec = vec ++ Vector(vec2.reverse)" & @CRLF & _
" " & @CRLF & _
" }" & @CRLF & _
" println(vec)" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")