import Foundation
let pattern = #"[\w\s]+[\w\(\):]+[\w\(\)<\-\s{=;+*%\.}]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
def g(n:Int) = {
var vec = Vector.fill(0)(Vector.fill(0)(1))
for (p <- 1 to n) {
var vec2 = Vector.fill(0)(1)
for (q <- (p-1)*n+1 to p*n) {
vec2 = vec2 ++ Vector(q)
}
if (p%2==1) vec = vec ++ Vector(vec2)
else vec = vec ++ Vector(vec2.reverse)
}
println(vec)
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)