package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w\s]+[\w\(\):]+[\w\(\)<\-\s{=;+*%\.}]+`)
var str = `def g(n:Int) = {
var vec = Vector.fill(0)(Vector.fill(0)(1))
for (p <- 1 to n) {
var vec2 = Vector.fill(0)(1)
for (q <- (p-1)*n+1 to p*n) {
vec2 = vec2 ++ Vector(q)
}
if (p%2==1) vec = vec ++ Vector(vec2)
else vec = vec ++ Vector(vec2.reverse)
}
println(vec)
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}