import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w\\s]+[\\w\\(\\):]+[\\w\\(\\)<\\-\\s\\{=;+*%\\.\\}]+";
final String string = "def g(n:Int) = {\n"
+ " var vec = Vector.fill(0)(Vector.fill(0)(1))\n"
+ " for (p <- 1 to n) {\n"
+ " var vec2 = Vector.fill(0)(1)\n"
+ " for (q <- (p-1)*n+1 to p*n) {\n"
+ " vec2 = vec2 ++ Vector(q)\n"
+ " }\n"
+ " if (p%2==1) vec = vec ++ Vector(vec2)\n"
+ " else vec = vec ++ Vector(vec2.reverse)\n"
+ " \n"
+ " }\n"
+ " println(vec)\n"
+ " }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}