#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))"
Local $sString = "skdsd .5 cups"
Local $sSubst = "\{3}\{4}1/2\{4}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)