import re
regex = re.compile(r"(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))")
test_str = "skdsd .5 cups"
subst = "\\{3}\\{4}1/2\\{4}"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)