import Foundation
let pattern = #"(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"skdsd .5 cups"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\{3}\{4}1/2\{4}"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}