// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(0\.5)|(\.5)|([0-9]*?)\.5((?(1)| ))").unwrap();
let string = "skdsd .5 cups";
let substitution = "\\{3}\\{4}1/2\\{4}";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}