#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) # set flag to allow verbose regexps" & @CRLF & _
"(?:[A-Z]\.)+ # abbreviations, e.g. U.S.A." & @CRLF & _
"|\d+(?:\.\d+)?% # percentages, 82%" & @CRLF & _
"|\w+(?:[-']\w+)* # permit word-internal hyphens and apostrophes" & @CRLF & _
"|[-.(]+ # double hyphen, ellipsis, and open parenthesis" & @CRLF & _
"|\S\w* # any sequence of word characters#" & @CRLF & _
"|[][{}.,;"'?():_`-] # these are separate tokens"
Local $sString = "How I'm 15.5% wholesome-looking U.S.A. we RADAR () [] {} you -- are, ... you?"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")