import re
regex = re.compile((r"(?x) # set flag to allow verbose regexps\n"
r"(?:[A-Z]\.)+ # abbreviations, e.g. U.S.A.\n"
r"|\d+(?:\.\d+)?% # percentages, 82%\n"
r"|\w+(?:[-']\w+)* # permit word-internal hyphens and apostrophes\n"
r"|[-.(]+ # double hyphen, ellipsis, and open parenthesis\n"
r"|\S\w* # any sequence of word characters#\n"
r"|[][{}.,;\"'?():_`-] # these are separate tokens"))
test_str = "How I'm 15.5% wholesome-looking U.S.A. we RADAR () [] {} you -- are, ... you?"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")