re = /(?x) # set flag to allow verbose regexps
(?:[A-Z]\.)+ # abbreviations, e.g. U.S.A.
|\d+(?:\.\d+)?% # percentages, 82%
|\w+(?:[-']\w+)* # permit word-internal hyphens and apostrophes
|[-.(]+ # double hyphen, ellipsis, and open parenthesis
|\S\w* # any sequence of word characters#
|[][{}.,;"'?():_`-] # these are separate tokens/
str = 'How I\'m 15.5% wholesome-looking U.S.A. we RADAR () [] {} you -- are, ... you?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end