import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?x) # set flag to allow verbose regexps\n"
+ "(?:[A-Z]\\.)+ # abbreviations, e.g. U.S.A.\n"
+ "|\\d+(?:\\.\\d+)?% # percentages, 82%\n"
+ "|\\w+(?:[-']\\w+)* # permit word-internal hyphens and apostrophes\n"
+ "|[-.(]+ # double hyphen, ellipsis, and open parenthesis\n"
+ "|\\S\\w* # any sequence of word characters#\n"
+ "|[][\\{\\}.,;\"'?():_`-] # these are separate tokens";
final String string = "How I'm 15.5% wholesome-looking U.S.A. we RADAR () [] {} you -- are, ... you?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}