const regex = new RegExp('(?x) # set flag to allow verbose regexps
(?:[A-Z]\\.)+ # abbreviations, e.g. U.S.A.
|\\d+(?:\\.\\d+)?% # percentages, 82%
|\\w+(?:[-\\']\\w+)* # permit word-internal hyphens and apostrophes
|[-.(]+ # double hyphen, ellipsis, and open parenthesis
|\\S\\w* # any sequence of word characters#
|[][{}.,;"\\'?():_`-] # these are separate tokens', 'g')
const str = `How I'm 15.5% wholesome-looking U.S.A. we RADAR () [] {} you -- are, ... you?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}