use strict;
my $str = '2019-04-10T11:07:58.846
2019-04-10T11:07:58.846+03:00
2019-04-10T11:07:58.846-03:00
2019-04-10T11:07:58.846+0300
2019-04-10T11:07:58.846-0300
2019-04-10T11:07:58.846Z
2019-04-10T11:07:58.846+03
2019-04-10T11:07:58.846-03';
my $regex = qr/(?:^(?<year>-?(?:[1-9][0-9]*)?[0-9]{4})-(?<month>1[0-2]|0[1-9])-(?<date>3[01]|0[1-9]|[12][0-9])T(?<hours>2[0-3]|[01][0-9]):(?<minutes>[0-5][0-9]):(?<seconds>[0-5][0-9])\.(?<ms>[0-9]+)?)(?<offset>Z|[+-][0-5][0-9](?::?[0-5][0-9])?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}