// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:^(?<year>-?(?:[1-9][0-9]*)?[0-9]{4})-(?<month>1[0-2]|0[1-9])-(?<date>3[01]|0[1-9]|[12][0-9])T(?<hours>2[0-3]|[01][0-9]):(?<minutes>[0-5][0-9]):(?<seconds>[0-5][0-9])\.(?<ms>[0-9]+)?)(?<offset>Z|[+-][0-5][0-9](?::?[0-5][0-9])?)?$").unwrap();
let string = "2019-04-10T11:07:58.846
2019-04-10T11:07:58.846+03:00
2019-04-10T11:07:58.846-03:00
2019-04-10T11:07:58.846+0300
2019-04-10T11:07:58.846-0300
2019-04-10T11:07:58.846Z
2019-04-10T11:07:58.846+03
2019-04-10T11:07:58.846-03";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}