import re
regex = re.compile(r"(?:^(?<year>-?(?:[1-9][0-9]*)?[0-9]{4})-(?<month>1[0-2]|0[1-9])-(?<date>3[01]|0[1-9]|[12][0-9])T(?<hours>2[0-3]|[01][0-9]):(?<minutes>[0-5][0-9]):(?<seconds>[0-5][0-9])\.(?<ms>[0-9]+)?)(?<offset>Z|[+-][0-5][0-9](?::?[0-5][0-9])?)?$", flags=re.MULTILINE)
test_str = ("2019-04-10T11:07:58.846\n"
"2019-04-10T11:07:58.846+03:00\n"
"2019-04-10T11:07:58.846-03:00\n"
"2019-04-10T11:07:58.846+0300\n"
"2019-04-10T11:07:58.846-0300\n"
"2019-04-10T11:07:58.846Z\n"
"2019-04-10T11:07:58.846+03\n"
"2019-04-10T11:07:58.846-03")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")