$re = '/(?:^(?<year>-?(?:[1-9][0-9]*)?[0-9]{4})-(?<month>1[0-2]|0[1-9])-(?<date>3[01]|0[1-9]|[12][0-9])T(?<hours>2[0-3]|[01][0-9]):(?<minutes>[0-5][0-9]):(?<seconds>[0-5][0-9])\.(?<ms>[0-9]+)?)(?<offset>Z|[+-][0-5][0-9](?::?[0-5][0-9])?)?$/m';
$str = '2019-04-10T11:07:58.846
2019-04-10T11:07:58.846+03:00
2019-04-10T11:07:58.846-03:00
2019-04-10T11:07:58.846+0300
2019-04-10T11:07:58.846-0300
2019-04-10T11:07:58.846Z
2019-04-10T11:07:58.846+03
2019-04-10T11:07:58.846-03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);