import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SET(.*?)WHERE";
final String string = "UPDATE pass\n"
+ "SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'\n"
+ "AND stato = 0\n"
+ "AND anno IN (2016, 2017, 2018);\n\n"
+ "UPDATE pass\n"
+ "SET stato = -3, descr_stato = 'Scartata'\n"
+ "WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);";
final String subst = "WHERE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}