# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"SET(.*?)WHERE"
test_str = ("UPDATE pass\n"
"SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'\n"
"AND stato = 0\n"
"AND anno IN (2016, 2017, 2018);\n\n"
"UPDATE pass\n"
"SET stato = -3, descr_stato = 'Scartata'\n"
"WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);")
subst = "WHERE"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.