import Foundation
let pattern = #"SET(.*?)WHERE"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
UPDATE pass
SET stato = -3, descr_stato = 'Scartata' WHERE pratica = '1458'
AND stato = 0
AND anno IN (2016, 2017, 2018);
UPDATE pass
SET stato = -3, descr_stato = 'Scartata'
WHERE pratica = '2383' AND stato = 0 AND anno IN (2020);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"WHERE"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)