#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{8}_\d{7}_)(?:CUPS[^_]+_)?(\S+)$"
Local $sString = "12345678_1234567_wgewgg_ewgewgw_gwgw_gwg" & @CRLF & _
"12345678_1234567_CUPS-Error_hgerhrh_herhr_herhe_heh"
Local $sSubst = "$1CUPS-ERROR_$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)