import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{8}_\\d{7}_)(?:CUPS[^_]+_)?(\\S+)$";
final String string = "12345678_1234567_wgewgg_ewgewgw_gwgw_gwg\n"
+ "12345678_1234567_CUPS-Error_hgerhrh_herhr_herhe_heh";
final String subst = "$1CUPS-ERROR_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}