using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d{8}_\d{7}_)(?:CUPS[^_]+_)?(\S+)$";
string substitution = @"$1CUPS-ERROR_$2";
string input = @"12345678_1234567_wgewgg_ewgewgw_gwgw_gwg
12345678_1234567_CUPS-Error_hgerhrh_herhr_herhe_heh";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}