$re = '/^(\d{8}_\d{7}_)(?:CUPS[^_]+_)?(\S+)$/m';
$str = '12345678_1234567_wgewgg_ewgewgw_gwgw_gwg
12345678_1234567_CUPS-Error_hgerhrh_herhr_herhe_heh';
$subst = "$1CUPS-ERROR_$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;