// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{8}_\d{7}_)(?:CUPS[^_]+_)?(\S+)$").unwrap();
let string = "12345678_1234567_wgewgg_ewgewgw_gwgw_gwg
12345678_1234567_CUPS-Error_hgerhrh_herhr_herhe_heh";
let substitution = "$1CUPS-ERROR_$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}