#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<a href="(https?://[^"]+)">.*?</a>"
Local $sString = "This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)