import Foundation
let pattern = #"<a href="(https?://[^"]+)">.*?</a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)