import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a href=\"(https?://[^\"]+)\">.*?</a>";
final String string = "This string contains a <a href=\"/local/link.html\">local link</a> and a <a href=\"http://remo.te/link.com\">remote link</a>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}