package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a href="(https?://[^"]+)">.*?</a>`)
var str = `This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}