use strict;
my $str = 'This string contains a <a href="/local/link.html">local link</a> and a <a href="http://remo.te/link.com">remote link</a>';
my $regex = qr~<a href="(https?://[^"]+)">.*?</a>~p;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";