using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<MAC_address>([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))";
string input = @"Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}