use strict;
my $str = 'Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1.';
my $regex = qr/(?P<MAC_address>([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}