// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?P<MAC_address>([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))").unwrap();
let string = "Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}