package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?P<MAC_address>([0-9A-Fa-f]{2}[:-]){5}([0-9A-Fa-f]{2}))`)
var str = `Username entry (random@somewhere.org) with length (253) created for mobile aa:aa:aa:aa:aa:aa
Username entry (hello) is deleted for mobile aa:aa:aa:aa:aa:aa
Guest user logged in with user account (randomnonexistentuser) MAC address aa:aa:aa:aa:aa:aa, IP address 127.0.0.1.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}