const regex = /(\d{2,4})(-|\/|:)(\d{1,2})(-|\/|:)(\d{1,2}) \d\d:\d\d(:\d\d){0,1}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2,4})(-|\\\/|:)(\\d{1,2})(-|\\\/|:)(\\d{1,2}) \\d\\d:\\d\\d(:\\d\\d){0,1}', '')
const str = `15-15-01 12:01:23
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}