import re
regex = re.compile(r"(\d{2,4})(-|\/|:)(\d{1,2})(-|\/|:)(\d{1,2}) \d\d:\d\d(:\d\d){0,1}")
test_str = ("15-15-01 12:01:23\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")